const regex = /ます|した|表現|彼/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ます|した|表現|彼', 'gm')
const str = `ある口の利けない人が歯ブラシを購入しようとしています。彼は、歯を磨くジェスチャーをして、店員にうまく伝える事ができたので目的の歯ブラシを買えました。次に、ある目の見えない人が、自分の目を隠すためにサングラスを買おうとしています。
問6 さて彼はどんな風に表現をすればうまく店員に伝わると思いますか。
目が見えない人にはもちろんステッキがあります。手を上げて、店員さんの注目を引きます。そして、店員さんがくる時直接サングラスが買いたいと言ってもいいです。
もしジェスチャーをしたいならば、目を閉じてまま眼鏡のジェスチャーをしてもいいです。
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}