use strict;
my $str = 'ある口の利けない人が歯ブラシを購入しようとしています。彼は、歯を磨くジェスチャーをして、店員にうまく伝える事ができたので目的の歯ブラシを買えました。次に、ある目の見えない人が、自分の目を隠すためにサングラスを買おうとしています。
問6 さて彼はどんな風に表現をすればうまく店員に伝わると思いますか。
目が見えない人にはもちろんステッキがあります。手を上げて、店員さんの注目を引きます。そして、店員さんがくる時直接サングラスが買いたいと言ってもいいです。
もしジェスチャーをしたいならば、目を閉じてまま眼鏡のジェスチャーをしてもいいです。
';
my $regex = qr/ます|した|表現|彼/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}