package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d+\.\d+\b`)
var str = `0.3324 - 0.6631 ABC0.1234 0.12 1.234 1.23 123.4567 1.2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}