$re = '/\b\d+\.\d+\b/m';
$str = '0.3324 - 0.6631 ABC0.1234 0.12 1.234 1.23 123.4567 1.2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);