re = /\b\d+\.\d+\b/m
str = '0.3324 - 0.6631 ABC0.1234 0.12 1.234 1.23 123.4567 1.2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end