# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s+(?=[A-Z])/\n/g;t' <<< "123123 123 A123"