$re = '/\s+(?=[A-Z])/';
$str = '123123 123 A123';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;