using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<key>^\w+):\s*(?<value>""(?:[^""\\]+|\\.|""\n"")+"")";
string input = @"keyOne: ""Lorem ipsum""
""dolor sit amet, ""
""consectetur \\\""adipiscin\""g elit""
keyTwo: ""Lorem ipsum""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}