$re = '/(?<key>^\w+):\s*(?<value>"(?:[^"\\\\]+|\\\\.|"\n")+")/m';
$str = 'keyOne: "Lorem ipsum"
"dolor sit amet, "
"consectetur \\\\\\"adipiscin\\"g elit"
keyTwo: "Lorem ipsum"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);