re = /(?<key>^\w+):\s*(?<value>"(?:[^"\\]+|\\.|"\n")+")/m
str = 'keyOne: "Lorem ipsum"
"dolor sit amet, "
"consectetur \\\\\\"adipiscin\\"g elit"
keyTwo: "Lorem ipsum"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end