package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)application\/json(;\s?charset=[\w\-]+)?`)
var str = `application/json
application/json; charset=utf-8
application/json; charset=UTF-8`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}