$re = '/application\/json(;\s?charset=[\w\-]+)?/m';
$str = 'application/json
application/json; charset=utf-8
application/json; charset=UTF-8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);