// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)application\/json(;\s?charset=[\w\-]+)?").unwrap();
let string = "application/json
application/json; charset=utf-8
application/json; charset=UTF-8";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}