#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?=(?=([^{}()<>]*\[+[^{}()<>]*\]+[^{}()<>]*))\1*$|(?=([^[\]()<>]*\{+[^[\]()<>]*\}+[^[\]()<>]*))\2*$|(?=([^[\]{}<>]*\(+[^[\]{}<>]*\)+[^[\]{}<>]*))\3*$|(?=([^[\]{}()]*\<+[^[\]{}()]*\>+[^[\]{}()]*))\4*$|(?=([^[\]{}()<>]*))\5*$)(?=(?=([^\"]*\“+[^\"]*\”+[^\"]*))\6*$|(?=([^“”]*\"+[^“”]*\"+[^“”]*))\7*$|(?=([^\"“”]*))\8*$)(?=(?=([^']*‘+[^']*’+[^']*))\9*$|(?=([^‘’]*'+[^‘’]*'+[^‘’]*))\10*$|(?=([^'‘’]*))\11*$)[A-Za-z0-9 \"“”'‘’()[\]{}<>«»\\\/?!&@£$€¥.,-]{3}[A-Za-z0-9 \"“”'‘’()[\]{}<>«»\\\/?!&@£$€¥.,\-*=#%+]{0,157}$"
Local $sString = "/^" & @CRLF & _
" (?=" & @CRLF & _
" (?=( [^{}()<>]* \[+ [^{}()<>]* \]+ [^{}()<>]* ))\1 *$|" & @CRLF & _
" (?=( [^[\]()<>]* \{+ [^[\]()<>]* \}+ [^[\]()<>]* ))\2 *$|" & @CRLF & _
" (?=( [^[\]{}<>]* \(+ [^[\]{}<>]* \)+ [^[\]{}<>]* ))\3 *$|" & @CRLF & _
" (?=( [^[\]{}()]* \<+ [^[\]{}()]* \>+ [^[\]{}()]* ))\4 *$|" & @CRLF & _
" (?=( [^[\]{}()<>]* ))\5 *$" & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
" (?=" & @CRLF & _
" (?=( [^\"]* \“+ [^\"]* \”+ [^\"]* ))\6 *$|" & @CRLF & _
" (?=( [^“”]* \"+ [^“”]* \"+ [^“”]* ))\7 *$|" & @CRLF & _
" (?=( [^\"“”]* ))\8 *$" & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
" (?=" & @CRLF & _
" (?=( [^']* ‘+ [^']* ’+ [^']* ))\9 *$|" & @CRLF & _
" (?=( [^‘’]* '+ [^‘’]* '+ [^‘’]* ))\10 *$|" & @CRLF & _
" (?=( [^'‘’]* ))\11 *$" & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
" [A-Za-z0-9 \"“”'‘’()[\]{}<>«»\\\/?!&@£$€¥.,-]{3}" & @CRLF & _
" [A-Za-z0-9 \"“”'‘’()[\]{}<>«»\\\/?!&@£$€¥.,\-*=#%+]{0,157}" & @CRLF & _
"$/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")