import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?=([^\\{\\}()<>]*\\[+[^\\{\\}()<>]*\\]+[^\\{\\}()<>]*))\\1*$|(?=([^[\\]()<>]*\\{+[^[\\]()<>]*\\}+[^[\\]()<>]*))\\2*$|(?=([^[\\]\\{\\}<>]*\\(+[^[\\]\\{\\}<>]*\\)+[^[\\]\\{\\}<>]*))\\3*$|(?=([^[\\]\\{\\}()]*\\<+[^[\\]\\{\\}()]*\\>+[^[\\]\\{\\}()]*))\\4*$|(?=([^[\\]\\{\\}()<>]*))\\5*$)(?=(?=([^\\\"]*\\“+[^\\\"]*\\”+[^\\\"]*))\\6*$|(?=([^“”]*\\\"+[^“”]*\\\"+[^“”]*))\\7*$|(?=([^\\\"“”]*))\\8*$)(?=(?=([^']*‘+[^']*’+[^']*))\\9*$|(?=([^‘’]*'+[^‘’]*'+[^‘’]*))\\10*$|(?=([^'‘’]*))\\11*$)[A-Za-z0-9 \\\"“”'‘’()[\\]\\{\\}<>«»\\\\\\/?!&@£$€¥.,-]{3}[A-Za-z0-9 \\\"“”'‘’()[\\]\\{\\}<>«»\\\\\\/?!&@£$€¥.,\\-*=#%+]{0,157}$";
final String string = "/^\n"
+ " (?=\n"
+ " (?=( [^{}()<>]* \\[+ [^{}()<>]* \\]+ [^{}()<>]* ))\\1 *$|\n"
+ " (?=( [^[\\]()<>]* \\{+ [^[\\]()<>]* \\}+ [^[\\]()<>]* ))\\2 *$|\n"
+ " (?=( [^[\\]{}<>]* \\(+ [^[\\]{}<>]* \\)+ [^[\\]{}<>]* ))\\3 *$|\n"
+ " (?=( [^[\\]{}()]* \\<+ [^[\\]{}()]* \\>+ [^[\\]{}()]* ))\\4 *$|\n"
+ " (?=( [^[\\]{}()<>]* ))\\5 *$\n"
+ " )\n\n"
+ " (?=\n"
+ " (?=( [^\\\"]* \\“+ [^\\\"]* \\”+ [^\\\"]* ))\\6 *$|\n"
+ " (?=( [^“”]* \\\"+ [^“”]* \\\"+ [^“”]* ))\\7 *$|\n"
+ " (?=( [^\\\"“”]* ))\\8 *$\n"
+ " )\n\n"
+ " (?=\n"
+ " (?=( [^']* ‘+ [^']* ’+ [^']* ))\\9 *$|\n"
+ " (?=( [^‘’]* '+ [^‘’]* '+ [^‘’]* ))\\10 *$|\n"
+ " (?=( [^'‘’]* ))\\11 *$\n"
+ " )\n\n"
+ " [A-Za-z0-9 \\\"“”'‘’()[\\]{}<>«»\\\\\\/?!&@£$€¥.,-]{3}\n"
+ " [A-Za-z0-9 \\\"“”'‘’()[\\]{}<>«»\\\\\\/?!&@£$€¥.,\\-*=#%+]{0,157}\n"
+ "$/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}