import re
regex = re.compile(r"^(?=(?=([^{}()<>]*\[+[^{}()<>]*\]+[^{}()<>]*))\1*$|(?=([^[\]()<>]*\{+[^[\]()<>]*\}+[^[\]()<>]*))\2*$|(?=([^[\]{}<>]*\(+[^[\]{}<>]*\)+[^[\]{}<>]*))\3*$|(?=([^[\]{}()]*\<+[^[\]{}()]*\>+[^[\]{}()]*))\4*$|(?=([^[\]{}()<>]*))\5*$)(?=(?=([^\"]*\“+[^\"]*\”+[^\"]*))\6*$|(?=([^“”]*\"+[^“”]*\"+[^“”]*))\7*$|(?=([^\"“”]*))\8*$)(?=(?=([^']*‘+[^']*’+[^']*))\9*$|(?=([^‘’]*'+[^‘’]*'+[^‘’]*))\10*$|(?=([^'‘’]*))\11*$)[A-Za-z0-9 \"“”'‘’()[\]{}<>«»\\\/?!&@£$€¥.,-]{3}[A-Za-z0-9 \"“”'‘’()[\]{}<>«»\\\/?!&@£$€¥.,\-*=#%+]{0,157}$")
test_str = ("/^\n"
" (?=\n"
" (?=( [^{}()<>]* \\[+ [^{}()<>]* \\]+ [^{}()<>]* ))\\1 *$|\n"
" (?=( [^[\\]()<>]* \\{+ [^[\\]()<>]* \\}+ [^[\\]()<>]* ))\\2 *$|\n"
" (?=( [^[\\]{}<>]* \\(+ [^[\\]{}<>]* \\)+ [^[\\]{}<>]* ))\\3 *$|\n"
" (?=( [^[\\]{}()]* \\<+ [^[\\]{}()]* \\>+ [^[\\]{}()]* ))\\4 *$|\n"
" (?=( [^[\\]{}()<>]* ))\\5 *$\n"
" )\n\n"
" (?=\n"
" (?=( [^\\\"]* \\“+ [^\\\"]* \\”+ [^\\\"]* ))\\6 *$|\n"
" (?=( [^“”]* \\\"+ [^“”]* \\\"+ [^“”]* ))\\7 *$|\n"
" (?=( [^\\\"“”]* ))\\8 *$\n"
" )\n\n"
" (?=\n"
" (?=( [^']* ‘+ [^']* ’+ [^']* ))\\9 *$|\n"
" (?=( [^‘’]* '+ [^‘’]* '+ [^‘’]* ))\\10 *$|\n"
" (?=( [^'‘’]* ))\\11 *$\n"
" )\n\n"
" [A-Za-z0-9 \\\"“”'‘’()[\\]{}<>«»\\\\\\/?!&@£$€¥.,-]{3}\n"
" [A-Za-z0-9 \\\"“”'‘’()[\\]{}<>«»\\\\\\/?!&@£$€¥.,\\-*=#%+]{0,157}\n"
"$/")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")