const regex = /delacruzkevin_\d+_\d+_lab1-2\.out/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('delacruzkevin_\\d+_\\d+_lab1-2\\.out', 'gm')
const str = `delacruzkevin_0_0_lab1-2.out
delacruzkevin_0_0_lab1-3.out
de lacruzkevin_0_0_lab1-2.out
delacruzkevin_12345_999999_lab1-2.out
delacruzkevin_12749261148_1284337922_lab1-2.exe
delacruzkevin_12749261148_1284337922_lab1-2.out
doejohn_123_456_lab1-2.out`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}