// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)delacruzkevin_\d+_\d+_lab1-2\.out").unwrap();
let string = "delacruzkevin_0_0_lab1-2.out
delacruzkevin_0_0_lab1-3.out
de lacruzkevin_0_0_lab1-2.out
delacruzkevin_12345_999999_lab1-2.out
delacruzkevin_12749261148_1284337922_lab1-2.exe
delacruzkevin_12749261148_1284337922_lab1-2.out
doejohn_123_456_lab1-2.out";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}