re = /delacruzkevin_\d+_\d+_lab1-2\.out/m
str = 'delacruzkevin_0_0_lab1-2.out
delacruzkevin_0_0_lab1-3.out
de lacruzkevin_0_0_lab1-2.out
delacruzkevin_12345_999999_lab1-2.out
delacruzkevin_12749261148_1284337922_lab1-2.exe
delacruzkevin_12749261148_1284337922_lab1-2.out
doejohn_123_456_lab1-2.out'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end