$re = '/(-?)([1-4]{1})([0-9]{6})\b/i';
$str = '991111-2111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);