const regex = /<(?'ins_libl'.*?)><(?'apt_nom'.*?)><(?'apt_telephone'.*?)><(?'tsy_lib'.*?)><(?'qsy_lib'.*?)><(?'num_externe'.*?)><(?'apt_localisation'.*?)><(?'urg_cd'.*?)><(?'commentaire_externe'.*?)>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(?\'ins_libl\'.*?)><(?\'apt_nom\'.*?)><(?\'apt_telephone\'.*?)><(?\'tsy_lib\'.*?)><(?\'qsy_lib\'.*?)><(?\'num_externe\'.*?)><(?\'apt_localisation\'.*?)><(?\'urg_cd\'.*?)><(?\'commentaire_externe\'.*?)>', 'gm')
const str = ` <Bari Via Adolfo Omodeo 49/a><DELLINO,SARA><+393484546557><Serramenti (porte, finestre, ecc)><Serramenti (porte, finestre, ecc)><41798><P2,torre ovest><3b-><Ciao, la porta del locale pulizie dell'open space torre ovest non presenta la griglia metallica. possiamo ripristinarla? Grazie Sara>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}