re = /<(?'ins_libl'.*?)><(?'apt_nom'.*?)><(?'apt_telephone'.*?)><(?'tsy_lib'.*?)><(?'qsy_lib'.*?)><(?'num_externe'.*?)><(?'apt_localisation'.*?)><(?'urg_cd'.*?)><(?'commentaire_externe'.*?)>/m
str = ' <Bari Via Adolfo Omodeo 49/a><DELLINO,SARA><+393484546557><Serramenti (porte, finestre, ecc)><Serramenti (porte, finestre, ecc)><41798><P2,torre ovest><3b-><Ciao, la porta del locale pulizie dell\'open space torre ovest non presenta la griglia metallica. possiamo ripristinarla? Grazie Sara>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end