using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SelfSourcedPrivate\.(\w+)\.";
string input = @"Fundamental.FinancialLineItem.FinancialLineItem.SelfSourcedPrivate.CUS.1.2017-09-07-1056.Full";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}