package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)SelfSourcedPrivate\.(\w+)\.`)
var str = `Fundamental.FinancialLineItem.FinancialLineItem.SelfSourcedPrivate.CUS.1.2017-09-07-1056.Full`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}