re = /SelfSourcedPrivate\.(\w+)\./m
str = 'Fundamental.FinancialLineItem.FinancialLineItem.SelfSourcedPrivate.CUS.1.2017-09-07-1056.Full'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end