using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*((?:(?:['""([{](?:[^'""()[\]{}]*|['""([{](?:[^'""()[\]{}]*|['""([{][^'""()[\]{}]*['"")}\]])*['"")}\]])*['"")}\]])|[^,])*?)?\s*(?:,\s*((?:(?:['""([{](?:[^'""()[\]{}]*|['""([{](?:[^'""()[\]{}]+|['""([{][^'""()[\]{}]*['"")}\]])*['"")}\]])*['"")}\]])|[^,])*?))?\s*(?:,\s*((?:(?:['""([{](?:[^'""()[\]{}]*|['""([{](?:[^'""()[\]{}]+|['""([{][^'""()[\]{}]*['"")}\]])*['"")}\]])*['"")}\]])|[^,])*?))?\s*$";
string input = @"([[a,'b)([]'],2, 'rr)'], { processOutput: () => { a, 111 } }, { processOutput: () => { a, 222 } })";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}