$re = '/^\s*((?:(?:[\'"([{](?:[^\'"()[\]{}]*|[\'"([{](?:[^\'"()[\]{}]*|[\'"([{][^\'"()[\]{}]*[\'")}\]])*[\'")}\]])*[\'")}\]])|[^,])*?)?\s*(?:,\s*((?:(?:[\'"([{](?:[^\'"()[\]{}]*|[\'"([{](?:[^\'"()[\]{}]+|[\'"([{][^\'"()[\]{}]*[\'")}\]])*[\'")}\]])*[\'")}\]])|[^,])*?))?\s*(?:,\s*((?:(?:[\'"([{](?:[^\'"()[\]{}]*|[\'"([{](?:[^\'"()[\]{}]+|[\'"([{][^\'"()[\]{}]*[\'")}\]])*[\'")}\]])*[\'")}\]])|[^,])*?))?\s*$/';
$str = '([[a,\'b)([]\'],2, \'rr)\'], { processOutput: () => { a, 111 } }, { processOutput: () => { a, 222 } })';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);