re = /^\s*((?:(?:['"([{](?:[^'"()[\]{}]*|['"([{](?:[^'"()[\]{}]*|['"([{][^'"()[\]{}]*['")}\]])*['")}\]])*['")}\]])|[^,])*?)?\s*(?:,\s*((?:(?:['"([{](?:[^'"()[\]{}]*|['"([{](?:[^'"()[\]{}]+|['"([{][^'"()[\]{}]*['")}\]])*['")}\]])*['")}\]])|[^,])*?))?\s*(?:,\s*((?:(?:['"([{](?:[^'"()[\]{}]*|['"([{](?:[^'"()[\]{}]+|['"([{][^'"()[\]{}]*['")}\]])*['")}\]])*['")}\]])|[^,])*?))?\s*$/
str = '([[a,\'b)([]\'],2, \'rr)\'], { processOutput: () => { a, 111 } }, { processOutput: () => { a, 222 } })'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end