$re = '/([^0-9]+)(\.)([0-9]+)(B)([0-9]+)(\.)([^0-9]+)(\.)(.+)/m';
$str = 'abcd.1B21.efg.hi.txt ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);