re = /([^0-9]+)(\.)([0-9]+)(B)([0-9]+)(\.)([^0-9]+)(\.)(.+)/m
str = 'abcd.1B21.efg.hi.txt '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end