using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a[^>]*([^""]*)[^>]*>([ 0-9a-zA-Z]+)<\/a>";
string input = @"<a href=""http://fonini.github.io"">Jonnas Fonini</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}