package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a[^>]*([^"]*)[^>]*>([ 0-9a-zA-Z]+)<\/a>`)
var str = `<a href="http://fonini.github.io">Jonnas Fonini</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}