#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?:[^"\n]*"){3}(?P<index_ks>[^"]+)"
Local $sString = " 2017-09-10 23:55:12,457 INFO device="PERIMETA-IMSSSC01HAM",index="P-CSCF-load.register.summaryPeriod1CurrentClctnIntv"; adjMthdStatISASentCount="0", adjMthdStatISARcvdCount="0", adjMthdStatESERcvdCount="0", adjMthdStatESESentCount="0""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")