import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^\"\\n]*\"){3}(?P<index_ks>[^\"]+)";
final String string = " 2017-09-10 23:55:12,457 INFO device=\"PERIMETA-IMSSSC01HAM\",index=\"P-CSCF-load.register.summaryPeriod1CurrentClctnIntv\"; adjMthdStatISASentCount=\"0\", adjMthdStatISARcvdCount=\"0\", adjMthdStatESERcvdCount=\"0\", adjMthdStatESESentCount=\"0\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}