package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:[^"\n]*"){3}(?P<index_ks>[^"]+)`)
var str = ` 2017-09-10 23:55:12,457 INFO device="PERIMETA-IMSSSC01HAM",index="P-CSCF-load.register.summaryPeriod1CurrentClctnIntv"; adjMthdStatISASentCount="0", adjMthdStatISARcvdCount="0", adjMthdStatESERcvdCount="0", adjMthdStatESESentCount="0"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}