using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\+\d(\(?)\d{3}(\)?)\d{7}$";
string input = @"+7(910)1052972";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}