$re = '/\+\d(\(?)\d{3}(\)?)\d{7}$/m';
$str = '+7(910)1052972';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);