const regex = /\+\d(\(?)\d{3}(\)?)\d{7}$/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\+\\d(\\(?)\\d{3}(\\)?)\\d{7}$', 'm')
const str = `+7(910)1052972`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}