package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)this,\s*'([^']*)'`)
var str = `widgetEvCall('handlers.onMenuClicked', event, this, 'http://www.stirwen.be/medias/documents/20181002_carte_octobre-novembre_2018_FR.pdf')
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}