re = /this,\s*'([^']*)'/m
str = 'widgetEvCall(\'handlers.onMenuClicked\', event, this, \'http://www.stirwen.be/medias/documents/20181002_carte_octobre-novembre_2018_FR.pdf\')
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end