$re = '/this,\s*\'([^\']*)\'/m';
$str = 'widgetEvCall(\'handlers.onMenuClicked\', event, this, \'http://www.stirwen.be/medias/documents/20181002_carte_octobre-novembre_2018_FR.pdf\')
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);