import re
regex = re.compile(r'"(\w+)"(?=:)', flags=re.MULTILINE)
test_str = "[\"key\": val, \"key2\": val, \"key3\": v, \"key5\": 34, \"key6\": \"ef\"]"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)