#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)><b>(.*)<\/b><\/a><\/td>"
Local $sString = "><b>MARTiiNEZ</b></a></td>" & @CRLF & _
" <td>30</td>" & @CRLF & _
" <td>" & @CRLF & _
" El Patrón (6) </td>" & @CRLF & _
" <td>" & @CRLF & _
" <font color="red">offline</font> </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td><a href="https://nes-newlife.de/profile/index/124"><b>Poison</b></a></td>" & @CRLF & _
" <td>32</td>" & @CRLF & _
" <td>" & @CRLF & _
" El dirigente (5) </td>" & @CRLF & _
" <td>" & @CRLF & _
" <font color="red">offline</font> </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td><a href="https://nes-newlife.de/profile/index/1333"><b>KaliboOM</b></a></td>" & @CRLF & _
" <td>28</td>" & @CRLF & _
" <td>" & @CRLF & _
" La Junta del Cartel (4) </td>" & @CRLF & _
" <td>" & @CRLF & _
" <font color="red">offline</font> </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td><a href="https://nes-newlife.de/profile/index/5013"><b>roY.</b></a></td>" & @CRLF & _
" <td>19</td>" & @CRLF & _
" <td>" & @CRLF & _
" La Junta del Cartel (4) </td>" & @CRLF & _
" <td>" & @CRLF & _
" <font color="red">offline</font> </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td><a href="https://nes-newlife.de/profile/index/5978"><b>PYREX</b></a></td>" & @CRLF & _
" <td>33</td>" & @CRLF & _
" <td>" & @CRLF & _
" La Junta del Cartel (4) </td>" & @CRLF & _
" <td>" & @CRLF & _
" <font color="green">online</font> </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td><a href="https://nes-newlife.de/profile/index/22462"><b>BaticZ</b></a></td>" & @CRLF & _
" <td>13</td>" & @CRLF & _
" <td>" & @CRLF & _
" La Junta del Cartel (4) </td>" & @CRLF & _
" <td>" & @CRLF & _
" <font color="red">offline</font> </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td><a href="https://nes-newlife.de/profile/index/24019"><b>FCKYEAAH</b></a></td>" & @CRLF & _
" <td>5</td>" & @CRLF & _
" <td>" & @CRLF & _
" La Junta del Cartel (4) </td>" & @CRLF & _
" <td>" & @CRLF & _
" <font color="red">offline</font> </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td><a href="https://nes-newlife.de/profile/index/4559"><b>Carbon</b></a></td>" & @CRLF & _
" <td>20</td>" & @CRLF & _
" <td>" & @CRLF & _
" El Barón de drogas (3) </td>" & @CRLF & _
" <td>" & @CRLF & _
" <font color="green">online</font> </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td><a href="https://nes-newlife.de/profile/index/132"><b>Costa</b></a></td>" & @CRLF & _
" <td>12</td>" & @CRLF & _
" <td>" & @CRLF & _
" Narco traficante (2) </td>" & @CRLF & _
" <td>" & @CRLF & _
" <font color="red">offline</font> </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td><a href="https://nes-newlife.de/profile/index/28512"><b>diabolo</b></a></td>" & @CRLF & _
" <td>5</td>" & @CRLF & _
" <td>" & @CRLF & _
" Narco traficante (2) </td>" & @CRLF & _
" <td>" & @CRLF & _
" <font color="red">offline</font> </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td><a href="https://nes-newlife.de/profile/index/28933"><b>STEVE</b></a></td>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")