# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"><b>(.*)<\/b><\/a><\/td>"
test_str = ("><b>MARTiiNEZ</b></a></td>\n"
" <td>30</td>\n"
" <td>\n"
" El Patrón (6) </td>\n"
" <td>\n"
" <font color=\"red\">offline</font> </td>\n"
" </tr>\n"
" <tr>\n"
" <td><a href=\"https://nes-newlife.de/profile/index/124\"><b>Poison</b></a></td>\n"
" <td>32</td>\n"
" <td>\n"
" El dirigente (5) </td>\n"
" <td>\n"
" <font color=\"red\">offline</font> </td>\n"
" </tr>\n"
" <tr>\n"
" <td><a href=\"https://nes-newlife.de/profile/index/1333\"><b>KaliboOM</b></a></td>\n"
" <td>28</td>\n"
" <td>\n"
" La Junta del Cartel (4) </td>\n"
" <td>\n"
" <font color=\"red\">offline</font> </td>\n"
" </tr>\n"
" <tr>\n"
" <td><a href=\"https://nes-newlife.de/profile/index/5013\"><b>roY.</b></a></td>\n"
" <td>19</td>\n"
" <td>\n"
" La Junta del Cartel (4) </td>\n"
" <td>\n"
" <font color=\"red\">offline</font> </td>\n"
" </tr>\n"
" <tr>\n"
" <td><a href=\"https://nes-newlife.de/profile/index/5978\"><b>PYREX</b></a></td>\n"
" <td>33</td>\n"
" <td>\n"
" La Junta del Cartel (4) </td>\n"
" <td>\n"
" <font color=\"green\">online</font> </td>\n"
" </tr>\n"
" <tr>\n"
" <td><a href=\"https://nes-newlife.de/profile/index/22462\"><b>BaticZ</b></a></td>\n"
" <td>13</td>\n"
" <td>\n"
" La Junta del Cartel (4) </td>\n"
" <td>\n"
" <font color=\"red\">offline</font> </td>\n"
" </tr>\n"
" <tr>\n"
" <td><a href=\"https://nes-newlife.de/profile/index/24019\"><b>FCKYEAAH</b></a></td>\n"
" <td>5</td>\n"
" <td>\n"
" La Junta del Cartel (4) </td>\n"
" <td>\n"
" <font color=\"red\">offline</font> </td>\n"
" </tr>\n"
" <tr>\n"
" <td><a href=\"https://nes-newlife.de/profile/index/4559\"><b>Carbon</b></a></td>\n"
" <td>20</td>\n"
" <td>\n"
" El Barón de drogas (3) </td>\n"
" <td>\n"
" <font color=\"green\">online</font> </td>\n"
" </tr>\n"
" <tr>\n"
" <td><a href=\"https://nes-newlife.de/profile/index/132\"><b>Costa</b></a></td>\n"
" <td>12</td>\n"
" <td>\n"
" Narco traficante (2) </td>\n"
" <td>\n"
" <font color=\"red\">offline</font> </td>\n"
" </tr>\n"
" <tr>\n"
" <td><a href=\"https://nes-newlife.de/profile/index/28512\"><b>diabolo</b></a></td>\n"
" <td>5</td>\n"
" <td>\n"
" Narco traficante (2) </td>\n"
" <td>\n"
" <font color=\"red\">offline</font> </td>\n"
" </tr>\n"
" <tr>\n"
" <td><a href=\"https://nes-newlife.de/profile/index/28933\"><b>STEVE</b></a></td>")
matches = re.search(regex, test_str, re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.