package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(https:\/\/www\.youtube\.com\/.*?)(?:\s|$)|(https:\/\/youtu\.be\/.*?)(?:\s|$)`)
var str = `https://www.youtube.com/watch?v=<video_id> test https://youtu.be/<video_id testasd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}