re = /(https:\/\/www\.youtube\.com\/.*?)(?:\s|$)|(https:\/\/youtu\.be\/.*?)(?:\s|$)/
str = 'https://www.youtube.com/watch?v=<video_id> test https://youtu.be/<video_id testasd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end