#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s+(?=\d+\.)"
Local $sString = "1. Moore, Roger" & @CRLF & _
"2. Connery, Sean" & @CRLF & _
"3. ...." & @CRLF & _
"100. Dalton, Timothy" & @CRLF & _
"110. Bronson, Pierce 111. Gomez, Selena 112. Portman, Nathalie" & @CRLF & _
""
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)