$re = '/\s+(?=\d+\.)/m';
$str = '1. Moore, Roger
2. Connery, Sean
3. ....
100. Dalton, Timothy
110. Bronson, Pierce 111. Gomez, Selena 112. Portman, Nathalie
';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;