import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+(?=\\d+\\.)";
final String string = "1. Moore, Roger\n"
+ "2. Connery, Sean\n"
+ "3. ....\n"
+ "100. Dalton, Timothy\n"
+ "110. Bronson, Pierce 111. Gomez, Selena 112. Portman, Nathalie\n";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}