# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ +(?=\d+\.)/\n/gm;t' <<< "1. Moore, Roger
2. Connery, Sean
3. ....
100. Dalton, Timothy
110. Bronson, Pierce 111. Gomez, Selena 112. Portman, Nathalie
"